[wpe-webkit] running as a systemd service prevents EventSource working

zan at falconsigh.net zan at falconsigh.net
Tue Nov 13 08:07:31 PST 2018

On Fri, Nov 2, 2018, at 4:43 PM, Aras Vaichas wrote:
> Hi,
> I have an unusual problem which I can't solve.
> I have wpewebkit running Javascript which calls EventSource("
>[1]"). I have an event server running at
> If I run cog from the command line, the EventSource connection
> succeeds,> If I run cog as a systemd service, the EventSource connection fails.
> Everything else on the web page runs fine, the only problem is the
> network.> My version of systemd doesn't have IP address black/white list
> support, so it can't be that.> I am running SELinux, but I've disabled it, and I don't see any
> SELinux audit messages.> 
> I captured the error returned from EventSource(), but it's just
> "{isTrusted:true}".> 
> The webkit process runs as root in both cases.
> I am at a loss why the Javascript would be affected by running it as a
> systemd service.
All networking operations should be piped through the NetworkProcess.
This process is spawned by the UIProcess (which in your case is the
cog process).
I don't have any experience with systemd and its service mechanism. As a
starting point, I would suggest using strace to examine dispatched
syscalls in the NetworkProcess, and seeing if something obvious comes up
from that.

> regards,
> Aras Vaichas
> _________________________________________________
> Do not post admin requests to the list. They will be ignored.
> webkit-wpe mailing list      (webkit-wpe at lists.webkit.org)
> Help/Unsubscribe/Update your Subscription:
> https://lists.webkit.org/mailman//listinfo/webkit-wpe


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-wpe/attachments/20181113/57ac3800/attachment.html>

More information about the webkit-wpe mailing list