[wpe-webkit] running as a systemd service prevents EventSource working

Aras Vaichas aras.vaichas at gmail.com
Fri Nov 2 08:43:19 PDT 2018


I have an unusual problem which I can't solve.

I have wpewebkit running Javascript which calls EventSource(""). I have an event server running at

If I run cog from the command line, the EventSource connection succeeds,
If I run cog as a systemd service, the EventSource connection fails.
Everything else on the web page runs fine, the only problem is the network.
My version of systemd doesn't have IP address black/white list support, so
it can't be that.
I am running SELinux, but I've disabled it, and I don't see any SELinux
audit messages.

I captured the error returned from EventSource(), but it's just

The webkit process runs as root in both cases.

I am at a loss why the Javascript would be affected by running it as a
systemd service.


Aras Vaichas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-wpe/attachments/20181102/e2b6c103/attachment.html>

More information about the webkit-wpe mailing list