[Webkit-unassigned] [Bug 229556] AX: Make PDFs loaded via <embed> accessible

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 10 11:36:08 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=229556

--- Comment #22 from Tyler Wilcock <tyler_w at apple.com> ---
> Why we need to split this method into two?
I split it into two so that we can handle hit tests of both NSPoint's and WebCore::IntPoints. The NSPoint hit test just converts the point to a WebCore::IntPoint and calls the IntPoint hit test method.

We could probably work entirely in NSPoints, but I'm having issues with the usual NSPoint forward declaration not being sufficient in Widget.h, so I'm inclined to leave it as-is unless you have a suggestion here.

/Users/twilco/projects/web/OpenSource/Source/WebCore/platform/Widget.h:180:44: error: variable has incomplete type 'NSPoint' (aka '_NSPoint')
  virtual id accessibilityHitTest(NSPoint) const { return nil; }

/Users/twilco/projects/web/OpenSource/Source/WebCore/platform/graphics/IntPoint.h:40:16: note: forward declaration of '_NSPoint'
typedef struct _NSPoint NSPoint;

I tried #include <Foundation/NSGeometry.h>, but that causes more issues:

error: expected unqualified-id @class NSString, Protocol;

error: unknown type name 'NSString'

And ~20 more similar errors.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210910/110e062a/attachment-0001.htm>


More information about the webkit-unassigned mailing list