[Webkit-unassigned] [Bug 191906] [WPE] Use new view state API from libwpe

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 27 08:00:00 PST 2018


--- Comment #6 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to Michael Catanzaro from comment #5)
> Comment on attachment 355719 [details]
> Patch
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=355719&action=review
> > Source/WebKit/UIProcess/API/C/wpe/WKView.h:49
> > +// Deprecated: Use wpe_view_backend_add_activity_state instead.
> >  WK_EXPORT void WKViewSetViewState(WKViewRef, WKViewState);
> I don't understand this. This API is not public, so it should be removed,
> not deprecated, right? And I can see it's not used anywhere, so that should
> be trivial.

It's public C API. It's not used inside WebKit itself, but used by applications. I agree we can just remove it, but once we bump the libwpe requirement.

> > Source/WebKit/UIProcess/API/wpe/WPEView.cpp:48
> Again, it should be renamed to WPE_CHECK_VERSION (or LIBWPE_CHECK_VERSION)
> and instead of checking whether it's defined or not, we should just require
> that version to build in order to avoid the extra check. It's not
> appropriate for the macro to be named WPE_BACKEND_CHECK_VERSION because it
> checks the version of libwpe, not the version of the WPE backend.

wpe backend was renamed as libwpe, is the same thing. I find it weird the lib prefix, the same way there's no LIBGTK_CHECK_VERSION nor LIBSOUP_CHECK_VERSION. The prefix used in all public APIs in libwpe is wpe, not libwpe.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181127/784b55aa/attachment.html>

More information about the webkit-unassigned mailing list