[Webkit-unassigned] [Bug 191906] [WPE] Use new view state API from libwpe

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 27 07:14:29 PST 2018


https://bugs.webkit.org/show_bug.cgi?id=191906

--- Comment #5 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 355719
  --> https://bugs.webkit.org/attachment.cgi?id=355719
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355719&action=review

> Source/WebKit/UIProcess/API/C/wpe/WKView.h:49
> +// Deprecated: Use wpe_view_backend_add_activity_state instead.
>  WK_EXPORT void WKViewSetViewState(WKViewRef, WKViewState);

I don't understand this. This API is not public, so it should be removed, not deprecated, right? And I can see it's not used anywhere, so that should be trivial.

> Source/WebKit/UIProcess/API/wpe/WPEView.cpp:48
> +#if !defined(WPE_BACKEND_CHECK_VERSION) || !WPE_BACKEND_CHECK_VERSION(1, 1, 0)

Again, it should be renamed to WPE_CHECK_VERSION (or LIBWPE_CHECK_VERSION) and instead of checking whether it's defined or not, we should just require that version to build in order to avoid the extra check. It's not appropriate for the macro to be named WPE_BACKEND_CHECK_VERSION because it checks the version of libwpe, not the version of the WPE backend.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181127/0a4fc82c/attachment.html>


More information about the webkit-unassigned mailing list