[Webkit-unassigned] [Bug 159144] Too much duplicated code in LayerTreeHosts implementations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 28 02:16:07 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=159144

--- Comment #6 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to comment #5)
> Comment on attachment 282123 [details]
> Try to fix EFL build
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=282123&action=review
> 
> > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedLayerTreeHost.cpp:207
> > +    UNUSED_PARAM(size);
> 
> Maybe using ASSERT_NOT_REACHED would be nice to use here.

Sure.

> > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/ThreadedCoordinatedLayerTreeHost.h:65
> > +    class CompositorClient final : public ThreadedCompositor::Client {
> 
> What about to add WTF_MAKE_NONCOPYABLE to make sure?

It's private and stack allocated only, LayerTreeHost is already non copyable, so I don't see how it can be copied.

> > Source/WebKit2/WebProcess/WebPage/LayerTreeHost.h:73
> >      virtual void sizeDidChange(const WebCore::IntSize& newSize) = 0;
> 
> What about change the name of it to the viewportSizeChanged, as we discussed
> earlier?

That doesn't belong to this patch, this is about sharing existing code, I avoided changes like that to make sure I don't break EFL port.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160628/226bf6a5/attachment.html>


More information about the webkit-unassigned mailing list