<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Too much duplicated code in LayerTreeHosts implementations"
href="https://bugs.webkit.org/show_bug.cgi?id=159144#c6">Comment # 6</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Too much duplicated code in LayerTreeHosts implementations"
href="https://bugs.webkit.org/show_bug.cgi?id=159144">bug 159144</a>
from <span class="vcard"><a class="email" href="mailto:cgarcia@igalia.com" title="Carlos Garcia Campos <cgarcia@igalia.com>"> <span class="fn">Carlos Garcia Campos</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=159144#c5">comment #5</a>)
<span class="quote">> Comment on <span class=""><a href="attachment.cgi?id=282123&action=diff" name="attach_282123" title="Try to fix EFL build">attachment 282123</a> <a href="attachment.cgi?id=282123&action=edit" title="Try to fix EFL build">[details]</a></span>
> Try to fix EFL build
>
> View in context:
> <a href="https://bugs.webkit.org/attachment.cgi?id=282123&action=review">https://bugs.webkit.org/attachment.cgi?id=282123&action=review</a>
>
> > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedLayerTreeHost.cpp:207
> > + UNUSED_PARAM(size);
>
> Maybe using ASSERT_NOT_REACHED would be nice to use here.</span >
Sure.
<span class="quote">> > Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/ThreadedCoordinatedLayerTreeHost.h:65
> > + class CompositorClient final : public ThreadedCompositor::Client {
>
> What about to add WTF_MAKE_NONCOPYABLE to make sure?</span >
It's private and stack allocated only, LayerTreeHost is already non copyable, so I don't see how it can be copied.
<span class="quote">> > Source/WebKit2/WebProcess/WebPage/LayerTreeHost.h:73
> > virtual void sizeDidChange(const WebCore::IntSize& newSize) = 0;
>
> What about change the name of it to the viewportSizeChanged, as we discussed
> earlier?</span >
That doesn't belong to this patch, this is about sharing existing code, I avoided changes like that to make sure I don't break EFL port.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>