[Webkit-unassigned] [Bug 153554] [webkitdirs] Clarify logic behind is{PortName} functions.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 28 03:14:10 PST 2016


--- Comment #5 from Konstantin Tokarev <annulen at yandex.ru> ---
Comment on attachment 270031
  --> https://bugs.webkit.org/attachment.cgi?id=270031

View in context: https://bugs.webkit.org/attachment.cgi?id=270031&action=review

>> Tools/ChangeLog:22
>> +        (buildCMakeProjectOrExit): Deleted.
> In a good quality change log, we make comments saying what we did to each function.

Thanks, will fix it.

>>> Tools/Scripts/webkitdirs.pm:103
>>> +    IOS      => "IOS",
>> This should probably be iOS.
> Yes, it should.

I know what is the right capitalization of "iOS", however I capitilized "I" here because other port names start with capital and these names are often used in the middle of word, e.g., isIOSWebKit(), and I guess there will be PlatformIOS.cmake when/if iOS port migrates to cmake.

However we can just ucfirst portName() where capitalization is needed.

>> Tools/Scripts/webkitdirs.pm:1060
>> +        $portName = "AppleWin";
> Don’t we want to use the constant here?

Yes, we do.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160128/039b19d7/attachment.html>

More information about the webkit-unassigned mailing list