[Webkit-unassigned] [Bug 152913] Refactor compareIterations to remove duplicate code.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 19 17:46:41 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=152913

Daniel Bates <dbates at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #268981|review?, commit-queue?      |review-, commit-queue-
              Flags|                            |

--- Comment #6 from Daniel Bates <dbates at webkit.org> ---
Comment on attachment 268981
  --> https://bugs.webkit.org/attachment.cgi?id=268981
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=268981&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/tests/tests.js:48
> +        queue = new MockBuildbotQueue();

This is error prone. Specifically, it is error prone to pass module state using global variables. From looking at the examples for setup()/tearDown() on <http://qunitjs.com/upgrade-guide-2.x/> and beforeEach()/afterEach() on <http://api.qunitjs.com/QUnit.module/> the preferred way to share such state is by modifying |this|.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160120/a504ffdf/attachment.html>


More information about the webkit-unassigned mailing list