[Webkit-unassigned] [Bug 152865] [mips] Add new or32 implementation after r194613

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 8 01:04:44 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=152865

--- Comment #3 from Julien Brianceau <jbriance at cisco.com> ---
Comment on attachment 268495
  --> https://bugs.webkit.org/attachment.cgi?id=268495
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=268495&action=review

>> Source/JavaScriptCore/assembler/MacroAssemblerMIPS.h:384
>> +        if (imm.m_value > 0 && imm.m_value < 65535

Please use a or32(TrustedImm32, RegisterID) call here to avoid code duplication, something like this:

        load32(dest.m_ptr, immTempRegister);
        or32(imm, dest);
        store32(immTempRegister, dest.m_ptr);


> I'm no mips expert, but should this be <= 65535?  There are other places in MacroAssemblerMIPS.h where this is also < 65535, but don't they all work using the 16-bit immediate value if the immediate value is equal to 65535, too?

You're right Alex, I also think this should be <= 0xffff. As there are other places in MacroAssemblerMIPS needing this change, maybe we could do this in a separate change ?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160108/7fe1d2fc/attachment-0001.html>


More information about the webkit-unassigned mailing list