[Webkit-unassigned] [Bug 156540] WebKit2 should allow clients to use different plug-in load policies for private browsing.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 14 15:12:40 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=156540

--- Comment #7 from iting_liu at apple.com ---
Comment on attachment 276356
  --> https://bugs.webkit.org/attachment.cgi?id=276356
Patch v2

View in context: https://bugs.webkit.org/attachment.cgi?id=276356&action=review

>> Source/WebKit2/UIProcess/WebProcessPool.h:187
>> +    enum class PageBrowsingMode { BrowsingModePrivate, BrowsingModeGeneral };
> 
> Please just name this
> 
> enum class PrivateBrowsing { Yes, No };
> 
> I don't think we use the term "Browsing Mode" anywhere else.

Sure.

>> Source/WebKit2/WebProcess/WebCoreSupport/WebPlatformStrategies.cpp:228
>> +    auto& hostsToPluginIdentifierData =  browsingMode == PageBrowsingMode::BrowsingModePrivate ? m_hostsToPluginIdentifierDataInPrivateBrowsing : m_hostsToPluginIdentifierData;
> 
> Extra spice here.

Oops. Removed.

>> Source/WebKit2/WebProcess/WebCoreSupport/WebPlatformStrategies.cpp:236
>> +        versionsToPolicies = versionsToPoliciesIterator->value;
> 
> I don't think this change is needed - it's not avoiding a hash lookup and it makes things harder to read.

Anders clairified that we don't need to use .contains beforehand; it'll just return a constructed object if it's not in there. I'll revert back to the original and get rid of .contains().

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160414/44ad28b8/attachment.html>


More information about the webkit-unassigned mailing list