[Webkit-unassigned] [Bug 156540] WebKit2 should allow clients to use different plug-in load policies for private browsing.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 14 13:49:08 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=156540

Anders Carlsson <andersca at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #276356|review?                     |review-
              Flags|                            |

--- Comment #6 from Anders Carlsson <andersca at apple.com> ---
Comment on attachment 276356
  --> https://bugs.webkit.org/attachment.cgi?id=276356
Patch v2

View in context: https://bugs.webkit.org/attachment.cgi?id=276356&action=review

> Source/WebKit2/UIProcess/WebProcessPool.h:187
> +    enum class PageBrowsingMode { BrowsingModePrivate, BrowsingModeGeneral };

Please just name this

enum class PrivateBrowsing { Yes, No };

I don't think we use the term "Browsing Mode" anywhere else.

> Source/WebKit2/WebProcess/WebCoreSupport/WebPlatformStrategies.cpp:228
> +    auto& hostsToPluginIdentifierData =  browsingMode == PageBrowsingMode::BrowsingModePrivate ? m_hostsToPluginIdentifierDataInPrivateBrowsing : m_hostsToPluginIdentifierData;

Extra spice here.

> Source/WebKit2/WebProcess/WebCoreSupport/WebPlatformStrategies.cpp:236
> -    if (policiesByIdentifier.contains(bundleIdentifierToSet))
> -        versionsToPolicies = policiesByIdentifier.get(bundleIdentifierToSet);
> +    auto versionsToPoliciesIterator = policiesByIdentifier.find(bundleIdentifierToSet);
> +    if (versionsToPoliciesIterator != policiesByIdentifier.end())
> +        versionsToPolicies = versionsToPoliciesIterator->value;

I don't think this change is needed - it's not avoiding a hash lookup and it makes things harder to read.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160414/694903ec/attachment-0001.html>


More information about the webkit-unassigned mailing list