[Webkit-unassigned] [Bug 116046] In Voice over, activating a fragment URL should transfer focus and caret to the destination

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 11 10:22:53 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=116046

--- Comment #20 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 275781
  --> https://bugs.webkit.org/attachment.cgi?id=275781
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=275781&action=review

>> Source/WebCore/dom/Document.cpp:693
>> +        m_focusNavigationStartingPoint = nullptr;
> 
> I'd call this focusNavigationStartingNode instead since "point" usually refers to either a graphical coordinate
> or a single point in DOM tree (e.g. Position / VisiblePosition).

On my second look, this is really
https://html.spec.whatwg.org/multipage/interaction.html#sequential-focus-navigation-starting-point
so we should call it exactly that: sequentialFocusNavigationStartingPoint with that URL in a comment.

>>> Source/WebCore/dom/Document.h:1479
>>> +    RefPtr<Range> m_focusNavigationStartingPoint;
>> 
>> Why are we using Range for this?
> 
> I'm using Range so that we can tell if the node has been removed from document tree and easily pick the next node. Is there a way to tell if a node has been removed or is no longer valid?

Is that really necessary?  Where in the HTML spec does it say that we need to use the next node in such a case?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160411/9cf6bacb/attachment.html>


More information about the webkit-unassigned mailing list