[Webkit-unassigned] [Bug 156467] New: Unify selectionStartEnd() methods.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 11 10:41:18 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=156467

            Bug ID: 156467
           Summary: Unify selectionStartEnd() methods.
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Layout and Rendering
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: zalan at apple.com
                CC: simon.fraser at apple.com

see https://bugs.webkit.org/show_bug.cgi?id=156448#c5

> Source/WebCore/rendering/InlineTextBox.cpp:607
> +    renderer().selectionStartEnd(selectionStart, selectionEnd);
Peculiar that this uses two out arguments and doesn’t even have get in its name. Should fix that.
> Source/WebCore/rendering/InlineTextBox.h:123
> +    std::pair<int, int> selectionStartEnd() const;
In other cases like this we sometimes use structures with names for the members rather than using a tuple. Sure would be nice to get rid of some those pairs of local variables and arguments using the same structure.

void SelectionSubtreeRoot::selectionStartEndPositions(int& startPos, int& endPos) const
void RenderObject::selectionStartEnd(int& spos, int& epos) const
std::pair<int, int> InlineTextBox::selectionStartEnd() const

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160411/4beeba29/attachment-0001.html>


More information about the webkit-unassigned mailing list