<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_ASSIGNED "
title="ASSIGNED - In Voice over, activating a fragment URL should transfer focus and caret to the destination"
href="https://bugs.webkit.org/show_bug.cgi?id=116046#c20">Comment # 20</a>
on <a class="bz_bug_link
bz_status_ASSIGNED "
title="ASSIGNED - In Voice over, activating a fragment URL should transfer focus and caret to the destination"
href="https://bugs.webkit.org/show_bug.cgi?id=116046">bug 116046</a>
from <span class="vcard"><a class="email" href="mailto:rniwa@webkit.org" title="Ryosuke Niwa <rniwa@webkit.org>"> <span class="fn">Ryosuke Niwa</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=275781&action=diff" name="attach_275781" title="patch">attachment 275781</a> <a href="attachment.cgi?id=275781&action=edit" title="patch">[details]</a></span>
patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=275781&action=review">https://bugs.webkit.org/attachment.cgi?id=275781&action=review</a>
<span class="quote">>> Source/WebCore/dom/Document.cpp:693
>> + m_focusNavigationStartingPoint = nullptr;
>
> I'd call this focusNavigationStartingNode instead since "point" usually refers to either a graphical coordinate
> or a single point in DOM tree (e.g. Position / VisiblePosition).</span >
On my second look, this is really
<a href="https://html.spec.whatwg.org/multipage/interaction.html#sequential-focus-navigation-starting-point">https://html.spec.whatwg.org/multipage/interaction.html#sequential-focus-navigation-starting-point</a>
so we should call it exactly that: sequentialFocusNavigationStartingPoint with that URL in a comment.
<span class="quote">>>> Source/WebCore/dom/Document.h:1479
>>> + RefPtr<Range> m_focusNavigationStartingPoint;
>>
>> Why are we using Range for this?
>
> I'm using Range so that we can tell if the node has been removed from document tree and easily pick the next node. Is there a way to tell if a node has been removed or is no longer valid?</span >
Is that really necessary? Where in the HTML spec does it say that we need to use the next node in such a case?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>