[Webkit-unassigned] [Bug 145581] Add basic Media Session support to HTMLMediaElement

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 3 14:20:54 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=145581

--- Comment #12 from Darin Adler <darin at apple.com> ---
Comment on attachment 254206
  --> https://bugs.webkit.org/attachment.cgi?id=254206
Patch (speculative Windows build fix)

View in context: https://bugs.webkit.org/attachment.cgi?id=254206&action=review

> Source/WebCore/Modules/mediasession/HTMLMediaElementMediaSession.h:32
> +#include <wtf/text/WTFString.h>

Don’t need this.

> Source/WebCore/Modules/mediasession/HTMLMediaElementMediaSession.h:36
> +class HTMLMediaElementMediaSession {

What determines the interface and name of this class? It seems quite strange and I am not sure exactly what it’s for.

I might omit the second occurrence of the word “Media” but I’m not sure enough of context to know if that suggestion is OK.

> Source/WebCore/Modules/mediasession/HTMLMediaElementMediaSession.h:42
> +    static const String& kind(HTMLMediaElement* element) { return element->kind(); }
> +    static void setKind(HTMLMediaElement* element, const String& kind) { return element->setKind(kind); }
> +
> +    static MediaSession* session(HTMLMediaElement*, bool&);
> +    static void setSession(HTMLMediaElement* element, MediaSession* session) { element->setSession(session); }

These should all take HTMLMediaElement&, not HTMLMediaElement*.

> Source/WebCore/html/HTMLMediaElement.h:422
> +    void setSession(MediaSession*);

Might want this to take RefPtr<MediaSession>&& instead, if callers are handing over ownership. If ownership is usually shared, then raw pointer is OK/better.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150603/928da711/attachment.html>


More information about the webkit-unassigned mailing list