[Webkit-unassigned] [Bug 144955] [ES6] Implement ES6 arrow function syntax. Parser of arrow function with execution as common function

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 3 14:03:30 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=144955

--- Comment #39 from GSkachkov <gskachkov at gmail.com> ---
(In reply to comment #38)
> (In reply to comment #37)
> > ERROR: Source/JavaScriptCore/parser/ParserTokens.h:79:  enum members should
> > use InterCaps with an initial capital letter.  [readability/enum_casing] [4]
> > ERROR: Source/JavaScriptCore/parser/Parser.h:752:  The parameter name
> > "functionParseType" adds no information, so it should be removed. 
> > [readability/parameter_name] [5]
> 
> Please fix these!

Not sure that I know how. Could you please suggest how to fix them?

1. Source/JavaScriptCore/parser/ParserTokens.h:79
I've added new value ARROWFUNCTION and followed the same style as all enums in this file http://trac.webkit.org/browser/trunk/Source/JavaScriptCore/parser/ParserTokens.h#L75

2. Source/JavaScriptCore/parser/Parser.h 
In this file I've added new parameter with default value in exist function. I've used default value to decrease number of changes, so to default value I had to add name of the parameter.

template <class TreeBuilder> TreeStatement parseStatement(TreeBuilder&, const Identifier*& directive, unsigned* directiveLiteralLength = 0, !!!!FunctionParseType functionParseType = StandardFunctionParseType!!!!)

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150603/49e5f1df/attachment.html>


More information about the webkit-unassigned mailing list