[Webkit-unassigned] [Bug 144038] Add PerfAutoRun to automate browser based performance benchmarks(e.g. Speedometer and JetStream)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 22 09:50:46 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=144038

--- Comment #4 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 251306
  --> https://bugs.webkit.org/attachment.cgi?id=251306
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=251306&action=review

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:74
> ++            console.log(dict);

debug? Do we want to keep this?

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:85
> ++            var http = new XMLHttpRequest();

xhr is a better name.

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:86
> ++            var url = '/report';

unnecessary variable

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:87
> ++            http.open("POST", url, true);

true can be omitted.

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:94
> ++                if(http.readyState == 4 && http.status == 200) {

XMLHttpRequest.DONE

> Tools/Scripts/PerfAutoRun/Patches/Speedometer.patch:95
> ++                    closeRequest = new XMLHttpRequest();

missing var

> Tools/Scripts/PerfAutoRun/PerfAutoRun.py:2
> +# coding : utf-8

I don't think we usually have this in our scripts.

> Tools/Scripts/PerfAutoRun/PerfAutoRun.py:3
> +import argparse

A blank line before the imports would be nicer IMHO.

> Tools/Scripts/PerfAutoRun/PerfAutoRun.py:29
> +            'OSX',

For command line arguments, I think it would be nice to avoid capital letters.

> Tools/Scripts/PerfAutoRun/PerfAutoRun.py:33
> +    # should we add chrome as an option? Well, chrome uses webkit in iOS.

# FIXME: Should we...

(extra FIXME: and capital letter)

> Tools/Scripts/PerfAutoRun/PerfAutoRun.py:39
> +            'Safari',

For command line arguments, I think it would be nice to avoid capital letters.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150422/8d82ff29/attachment.html>


More information about the webkit-unassigned mailing list