[Webkit-unassigned] [Bug 143879] Network Cache: Read resource record and body in parallel

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 17 09:39:41 PDT 2015


Chris Dumez <cdumez at apple.com> changed:

           What    |Removed                     |Added
 Attachment #251023|review?                     |review+
              Flags|                            |

--- Comment #3 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 251023
  --> https://bugs.webkit.org/attachment.cgi?id=251023
more thread safety

View in context: https://bugs.webkit.org/attachment.cgi?id=251023&action=review


> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:122
>          auto filter = std::make_unique<ContentsFilter>();

Maybe rename this one to recordFilter now that we have another filter?

> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:124
>          size_t size = 0;

Ditto, I would rename this to recordsSize for clarity as it doesn't account for bodies.

> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:189
>  bool Storage::mayContain(const Key& key) const

Maybe we can add a mayContainBodyBlob() now? For consistency. Then rename this one to mayContainRecord().
I know it is only used in one place right now but I still like it.

> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:421
> +void Storage::dispatchReadOperation(ReadOperation& read)

Not a big fan of 'read' variable name. Maybe something like readOperation would be more readable here.

> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:435
> +    bool shouldGetBodyBlob = !m_bodyBlobFilter || m_bodyBlobFilter->mayContain(read.key.hash());

I would use a utility function like we do for the records filter already.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150417/91f269e4/attachment.html>

More information about the webkit-unassigned mailing list