[Webkit-unassigned] [Bug 143879] Network Cache: Read resource record and body in parallel

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 17 09:41:56 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=143879

--- Comment #4 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 251023
  --> https://bugs.webkit.org/attachment.cgi?id=251023
more thread safety

View in context: https://bugs.webkit.org/attachment.cgi?id=251023&action=review

> Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.h:110
> +        std::atomic<unsigned> finishedCount { 0 };

Not sure it is best but maybe we could use 2 booleans instead (e.g. hasReadRecord, hasReadBody). Might be a little more readable than expecting this integer to be 2. Your call.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150417/2ad30329/attachment.html>


More information about the webkit-unassigned mailing list