<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:cdumez&#64;apple.com" title="Chris Dumez &lt;cdumez&#64;apple.com&gt;"> <span class="fn">Chris Dumez</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Network Cache: Read resource record and body in parallel"
   href="https://bugs.webkit.org/show_bug.cgi?id=143879">bug 143879</a>
        <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Attachment #251023 Flags</td>
           <td>review?
           </td>
           <td>review+
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Network Cache: Read resource record and body in parallel"
   href="https://bugs.webkit.org/show_bug.cgi?id=143879#c3">Comment # 3</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Network Cache: Read resource record and body in parallel"
   href="https://bugs.webkit.org/show_bug.cgi?id=143879">bug 143879</a>
              from <span class="vcard"><a class="email" href="mailto:cdumez&#64;apple.com" title="Chris Dumez &lt;cdumez&#64;apple.com&gt;"> <span class="fn">Chris Dumez</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=251023&amp;action=diff" name="attach_251023" title="more thread safety">attachment 251023</a> <a href="attachment.cgi?id=251023&amp;action=edit" title="more thread safety">[details]</a></span>
more thread safety

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=251023&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=251023&amp;action=review</a>

r=me

<span class="quote">&gt; Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:122
&gt;          auto filter = std::make_unique&lt;ContentsFilter&gt;();</span >

Maybe rename this one to recordFilter now that we have another filter?

<span class="quote">&gt; Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:124
&gt;          size_t size = 0;</span >

Ditto, I would rename this to recordsSize for clarity as it doesn't account for bodies.

<span class="quote">&gt; Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:189
&gt;  bool Storage::mayContain(const Key&amp; key) const</span >

Maybe we can add a mayContainBodyBlob() now? For consistency. Then rename this one to mayContainRecord().
I know it is only used in one place right now but I still like it.

<span class="quote">&gt; Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:421
&gt; +void Storage::dispatchReadOperation(ReadOperation&amp; read)</span >

Not a big fan of 'read' variable name. Maybe something like readOperation would be more readable here.

<span class="quote">&gt; Source/WebKit2/NetworkProcess/cache/NetworkCacheStorage.cpp:435
&gt; +    bool shouldGetBodyBlob = !m_bodyBlobFilter || m_bodyBlobFilter-&gt;mayContain(read.key.hash());</span >

I would use a utility function like we do for the records filter already.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>