[Webkit-unassigned] [Bug 131050] Web Inspector: Provide a way for JSContext console to log to system console

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 1 13:23:14 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=131050





--- Comment #5 from Joseph Pecoraro <joepeck at webkit.org>  2014-04-01 13:23:32 PST ---
(In reply to comment #4)
> (From update of attachment 228304 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=228304&action=review
> 
> > Source/JavaScriptCore/inspector/JSConsoleClient.cpp:62
> > +    Boolean preference = CFPreferencesGetAppBooleanValue(CFSTR("JavaScriptCoreConsoleLogToSystemConsole"), kCFPreferencesCurrentApplication, &keyExistsAndHasValidFormat);
> 
> JavaScriptCoreConsoleLogToSystemConsole implies only console.log is printed. A verb like "output" would help too. Maybe: OutputJavaScriptCoreConsoleToSystemConsole. Does this work for WebKit too? Maybe OutputJavaScriptConsoleToSystemConsole if so.

I want the preference to start with "JavaScriptCore" as a namespacing thing. There is one other CFPreference in JavaScriptCore and it does the same.

Any preference among these?

    - "JavaScriptCoreOutputConsoleMessagesToSystemConsole"
    - "JavaScriptCoreLogConsoleMessagesToSystemConsole"
    - "JavaScriptCoreConsoleLogToSystemConsoleEnabled"


> > Source/JavaScriptCore/inspector/JSConsoleClient.cpp:82
> > +    if (JSConsoleClient::logToSystemConsole())
> 
> No need for JSConsoleClient:: right?

Correct, but I prefer the explicit prefix because it makes it obvious that this is a static/class function and not a member function. If we have a style one way or the other I can match.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list