[Webkit-unassigned] [Bug 131050] Web Inspector: Provide a way for JSContext console to log to system console

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 1 13:32:29 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=131050





--- Comment #6 from Timothy Hatcher <timothy at apple.com>  2014-04-01 13:32:47 PST ---
(From update of attachment 228304)
View in context: https://bugs.webkit.org/attachment.cgi?id=228304&action=review

>>> Source/JavaScriptCore/inspector/JSConsoleClient.cpp:62
>>> +    Boolean preference = CFPreferencesGetAppBooleanValue(CFSTR("JavaScriptCoreConsoleLogToSystemConsole"), kCFPreferencesCurrentApplication, &keyExistsAndHasValidFormat);
>> 
>> JavaScriptCoreConsoleLogToSystemConsole implies only console.log is printed. A verb like "output" would help too. Maybe: OutputJavaScriptCoreConsoleToSystemConsole. Does this work for WebKit too? Maybe OutputJavaScriptConsoleToSystemConsole if so.
> 
> I want the preference to start with "JavaScriptCore" as a namespacing thing. There is one other CFPreference in JavaScriptCore and it does the same.
> 
> Any preference among these?
> 
>     - "JavaScriptCoreOutputConsoleMessagesToSystemConsole"
>     - "JavaScriptCoreLogConsoleMessagesToSystemConsole"
>     - "JavaScriptCoreConsoleLogToSystemConsoleEnabled"

Prefixing with JSC makes sense. I like JavaScriptCoreOutputConsoleMessagesToSystemConsole.

>>> Source/JavaScriptCore/inspector/JSConsoleClient.cpp:82
>>> +    if (JSConsoleClient::logToSystemConsole())
>> 
>> No need for JSConsoleClient:: right?
> 
> Correct, but I prefer the explicit prefix because it makes it obvious that this is a static/class function and not a member function. If we have a style one way or the other I can match.

It looks like you are calling a base class method with this syntax. I know I have seen other static methods called without a prefix in WebCore. Not sure there is a formal style guide.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list