[Webkit-unassigned] [Bug 56375] [Qt] PageGroup::closeLocalStorage() should be called when the app quits

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 2 13:22:09 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=56375


Andreas Kling <kling at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #91961|review?, commit-queue?      |review-
               Flag|                            |




--- Comment #10 from Andreas Kling <kling at webkit.org>  2011-05-02 13:22:09 PST ---
(From update of attachment 91961)
View in context: https://bugs.webkit.org/attachment.cgi?id=91961&action=review

> Source/WebKit/qt/ChangeLog:10
> +        Added an instance count to QWebPage.  Now when the last QWebPage

Two spaces after "QWebPage."

> Source/WebKit/qt/Api/qwebpage.cpp:166
> +    WebCore::iconDatabase().close();

This should be inside #if ENABLE(ICONDATABASE)

> Source/WebKit/qt/Api/qwebpage.cpp:167
> +    WebCore::PageGroup::closeLocalStorage();

No need for the WebCore:: prefix here (or the line above.)

> Source/WebKit/qt/Api/qwebpage.cpp:393
> +    // if destroying last WebPage instance. Release resources.

Comments should be in sentence style:
// If destroying last QWebPage instance, release resources.

> Source/WebKit/qt/Api/qwebpage_p.h:214
> +    static int instanceCount; // Used to clean up when last instance destroyed.

Unnecessary comment.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list