[Webkit-unassigned] [Bug 45443] [GTK] Support for viewport meta tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 21 04:46:32 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45443





--- Comment #38 from Joone Hur <joone at kldp.org>  2010-10-21 04:46:31 PST ---
(In reply to comment #37) 
> 2) Rename webkit_web_view_set_viewport_attributes to webkit_web_view_init_viewport_attributes.
> 
> We need this function to set the deskopWidth, deviceWidth/Height, and deviceDPI. Because WebKit cannot get these values by itself. In addition, if these values are changed, a UA should call this function to initialize the viewport attributes again.

We are able to get the deviceWidth/Height and deviceDPI in WebKitGtk as follow,

static void webkit_web_view_init(WebKitWebView* webView)
{
...
 // Attach a new WebKitViewportAttrbutes object given the viewport configuration values.
    GdkScreen* screen = gtk_widget_get_screen(GTK_WIDGET(webView));
    priv->viewportAttributes = adoptPlatformRef(webkit_viewport_attributes_new(980, gdk_screen_get_width(screen), gdk_screen_get_height(screen), webViewGetDPI(webView)));

Therefore, we don't need to call webkit_web_view_init_viewport_attributes on real devices, but DRT still needs  this function to initialize the viewport attributes manually.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list