[Webkit-unassigned] [Bug 45443] [GTK] Support for viewport meta tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 20 17:20:09 PDT 2010


https://bugs.webkit.org/show_bug.cgi?id=45443





--- Comment #37 from Joone Hur <joone at kldp.org>  2010-10-20 17:20:08 PST ---
Thank you for your comments.
Before updating the patch, I'd like to confirm the following issues,

1) Add "void webkit_web_view_recompute_viewport_attributes(WebKitWebView* webView, gint availableWidth, gint availableHeight) instead of webkit_viewport_recompute to trigger a viewport-attribute-changed signal.

It seems to be easier to trigger the signal in WebKitWebView.  Also, we still need the availableWidth/Height parameters although these values are able to be obtained in WebKit. Because, DRT needs this function given arbitrary availableWidth/height for testing. 
Instead, we can remove webkit_viewport_attributes_computation.

2) Rename webkit_web_view_set_viewport_attributes to webkit_web_view_init_viewport_attributes.

We need this function to set the deskopWidth, deviceWidth/Height, and deviceDPI. Because WebKit cannot get these values by itself. In addition, if these values are changed, a UA should call this function to initialize the viewport attributes again.

As kov commented, we usually expect that a set would set the same object used by the get. So I'm going to rename this function as above.

Any suggestions are appreciated.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list