[Webkit-unassigned] [Bug 41842] Add feature detection support for NRWT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 6 14:17:52 PDT 2010


--- Comment #13 from Dirk Pranke <dpranke at chromium.org>  2010-08-06 14:17:52 PST ---
(In reply to comment #9)
> (From update of attachment 61033 [details])
> OK.  Seems we should implement this for the other webkit platforms as well.
> directories_to_skip is a bad name, since it's about skipping directories for disabled features.

I think you can look at this a couple of different ways. One way to look at this is that all it is is a list of directories to skip, but the caller doesn't know why the port wants to skip them.

Another way is to make this a "features to disable" (or skip) call -- not directories -- and make the features->directory mapping generic (or at least a different, overridable call), and that would suggest a different name.

A third way is to think of this is as "directories to skip because the features are disabled". Of course, that would be a really long method name, even by Eric's standards. It's not obvious to me what a better  name than "directories_to_skip" would be.

I'm actually fine with any of the three approaches. The second is the most well-factored, but it might be overkill. 

Whatever you do pick, there should be a docstring describing the contract, though.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list