[Webkit-unassigned] [Bug 14998] Full page zooming support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 10 02:58:25 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=14998





------- Comment #30 from george.wright at collabora.co.uk  2007-10-10 02:58 PDT -------
(In reply to comment #29)
> (From update of attachment 16587 [edit])
> +    const_cast<PlatformMouseEvent&>(event).scale(scaleFactor());
> 
> This feels ugly to me. If it's not possible for the scale factor to change
> while an event is being handled (is it?), we could generate the scaled position
> in the Platform*Event constructors. If it turns out that most users of the
> Platform*Event types really want to be dealing with the scaled coordinates, we
> could even make Platform*Event::pos() return the scaled position, and come up
> with a new method to return the unscaled one (I like Darin's idea of coming up
> with better names for these than just [un]scaled).
> 
> I think you should revert the variable renames in EventHandler.cpp to make the
> diff smaller.

The problem with that is that the Platform*Event constructors don't have access
to the Page object and so can't get the current scale factor, unless I'm
missing something fantastically obvious.

> I also agree with Darin that the miscellaneous Cairo changes should be split
> into a separate bug/patch.

To be honest, those Cairo changes are more of a hack than anything; ideally
we'd want to use EXTEND_PAD but that's not currently implemented in Cairo as
far as I know.

> Have you thought about Darin's comments re: not multiplying by the scale factor
> in high-level code?

Yes - I'll take a look at that when I have some time.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list