[Webkit-unassigned] [Bug 14998] Full page zooming support
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Oct 10 08:09:26 PDT 2007
http://bugs.webkit.org/show_bug.cgi?id=14998
------- Comment #31 from aroben at apple.com 2007-10-10 08:09 PDT -------
(In reply to comment #30)
> (In reply to comment #29)
> > (From update of attachment 16587 [edit] [edit])
> > + const_cast<PlatformMouseEvent&>(event).scale(scaleFactor());
> >
> > This feels ugly to me. If it's not possible for the scale factor to change
> > while an event is being handled (is it?), we could generate the scaled position
> > in the Platform*Event constructors. If it turns out that most users of the
> > Platform*Event types really want to be dealing with the scaled coordinates, we
> > could even make Platform*Event::pos() return the scaled position, and come up
> > with a new method to return the unscaled one (I like Darin's idea of coming up
> > with better names for these than just [un]scaled).
>
> The problem with that is that the Platform*Event constructors don't have access
> to the Page object and so can't get the current scale factor, unless I'm
> missing something fantastically obvious.
Couldn't you pass in the scale factor as an argument to the constructors?
--
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list