[Webkit-unassigned] [Bug 14998] Full page zooming support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 8 11:42:11 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=14998


aroben at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #16587|review?                     |review-
               Flag|                            |




------- Comment #29 from aroben at apple.com  2007-10-08 11:42 PDT -------
(From update of attachment 16587)
+    const_cast<PlatformMouseEvent&>(event).scale(scaleFactor());

This feels ugly to me. If it's not possible for the scale factor to change
while an event is being handled (is it?), we could generate the scaled position
in the Platform*Event constructors. If it turns out that most users of the
Platform*Event types really want to be dealing with the scaled coordinates, we
could even make Platform*Event::pos() return the scaled position, and come up
with a new method to return the unscaled one (I like Darin's idea of coming up
with better names for these than just [un]scaled).

I think you should revert the variable renames in EventHandler.cpp to make the
diff smaller.

I also agree with Darin that the miscellaneous Cairo changes should be split
into a separate bug/patch.

Have you thought about Darin's comments re: not multiplying by the scale factor
in high-level code?


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list