[webkit-reviews] review granted: [Bug 208703] [WebAuthn] Customize a bit more on the macOS LocalAuthentication prompt : [Attachment 392771] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Mar 8 23:14:36 PDT 2020


Darin Adler <darin at apple.com> has granted Jiewen Tan <jiewen_tan at apple.com>'s
request for review:
Bug 208703: [WebAuthn] Customize a bit more on the macOS LocalAuthentication
prompt
https://bugs.webkit.org/show_bug.cgi?id=208703

Attachment 392771: Patch

https://bugs.webkit.org/attachment.cgi?id=392771&action=review




--- Comment #4 from Darin Adler <darin at apple.com> ---
Comment on attachment 392771
  --> https://bugs.webkit.org/attachment.cgi?id=392771
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=392771&action=review

> Source/WebCore/en.lproj/Localizable.strings:887
> +"Touch ID to allow signning into â%@â with Touch ID." = "Touch ID to allow
signning into â%@â with Touch ID.";

Spelling error here in the word "signing"

> Source/WebCore/platform/LocalizedStrings.cpp:1218
> +    return formatLocalizedString(WEB_UI_CFSTRING("Touch ID to allow signning
into â%@â with Touch ID.", "Allow using Touch ID to sign into the specified
website on this device"), rpId.createCFString().get());

Ditto.

> Source/WebCore/platform/LocalizedStrings.h:344
> +    WEBCORE_EXPORT String makeCredentialTouchIDPromptTitle(const String&
rpId);

Do we really have to call this "rpId"? Are there words we could use instead?

> Source/WebKit/UIProcess/WebAuthentication/Cocoa/LocalConnection.mm:52
> +#elif PLATFORM(MAC)

I think we should just use #else here.


More information about the webkit-reviews mailing list