[webkit-reviews] review denied: [Bug 20013] Windows AX heuristics are poor : [Attachment 22599] Patch to navigate between accessibility parent, children and siblings.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 21 22:13:34 PDT 2008


Jon Honeycutt <jhoneycutt at apple.com> has denied Eric Seidel <eric at webkit.org>'s
request for review:
Bug 20013: Windows AX heuristics are poor
https://bugs.webkit.org/show_bug.cgi?id=20013

Attachment 22599: Patch to navigate between accessibility parent, children and
siblings.
https://bugs.webkit.org/attachment.cgi?id=22599&action=edit

------- Additional Comments from Jon Honeycutt <jhoneycutt at apple.com>
+	 Add functions to navigate properly between the accessibility parent
+	 and accessibility children. 

I'm not sure that this description gets the point across. The bug is that,
currently, calling previousSibling, nextSibling, etc on an accessibility object
could return items that shouldn't be exposed because their accessibility is
ignored, correct? This should be more explicit in the ChangeLog.

This patch contains the previous patch's changes to children/addChildren. These
should be removed from this patch.

I'm not sure that this patch will work properly if objects in the DOM are moved
between parents, or if objects are added or removed. This will need a layout
tests that confirm that, after these sorts of DOM operations, navigating
between elements gives the expected result. If you find that the behavior is
not correct, you might look at how parentObjectUnignored works and follow the
same method.

I think the name of the new methods should be consistent with the name of the
parentObjectUnignored method, so the methods should be renamed
nextSiblingUnignored, previousSiblingUnignored, and so on.

+    AccessibilityObject* parentObj = m_object->parentObjectUnignored();
+
+    if (parentObj)  {
+	 *parent = static_cast<IDispatch*>(wrapper(parentObj));
+	 (*parent)->AddRef();
+	 return S_OK;
+    }
+
This is a separate bug that could have its own patch.

Thanks, Sankar! r- for these issues.


More information about the webkit-reviews mailing list