[webkit-reviews] review denied: [Bug 17952] Add "--cairo" flag to 'build-webkit' command : [Attachment 20445] Support cairo via command-line flag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 14 08:27:43 PDT 2008


Adam Roben (aroben) <aroben at apple.com> has denied Brent Fulgham
<bfulgham at gmail.com>'s request for review:
Bug 17952: Add "--cairo" flag to 'build-webkit' command
http://bugs.webkit.org/show_bug.cgi?id=17952

Attachment 20445: Support cairo via command-line flag
http://bugs.webkit.org/attachment.cgi?id=20445&action=edit

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
+    my $isCairo = grep(/^--cairo$/i, @ARGV);
+
     for my $i (0 .. $#ARGV) {
	 my $opt = $ARGV[$i];
	 if ($opt =~ /^--debug$/i || $opt =~ /^--devel/i) {
	     splice(@ARGV, $i, 1);
	     $passedConfiguration = "Debug";
+	     $passedConfiguration .= "_Cairo" if $isCairo;
	     return;
	 }
	 if ($opt =~ /^--release$/i || $opt =~ /^--deploy/i) {
	     splice(@ARGV, $i, 1);
	     $passedConfiguration = "Release";
+	     $passedConfiguration .= "_Cairo" if $isCairo;
	     return;
	 }

This seems very Windows-specific, since only the Windows .vcproj files have
these _Cairo configurations. Perhaps the flag should only have an effect on
Windows? Perhaps it should be named something more specific, like
--cairo-win32?


More information about the webkit-reviews mailing list