[webkit-dev] dump-class-layout script not working

Simon Fraser simon.fraser at apple.com
Mon Nov 5 05:17:12 PST 2018

Dump-class-layout uses the lldb python bindings. Maybe those are not available on your platform?

I think we’ve only ever tried it on macOS. What platform are you trying on?


> On Nov 4, 2018, at 12:43 PM, Frank Jaeger <fjaeger77 at outlook.com> wrote:
> Hello. First of all I'm really sorry if this is the wrong mailing list to post to, webkit-help would have probably been better but it doesn't seem very active.
> I run into some problems while trying to use the dump-class-layout script (found in Tools/Scripts/). I built WebKit using the build-webkit script with the --debug flag.
> After building, I tried to run the dump-class-layout script with the following arguments:
> ./Tools/Scripts/dump-class-layout --architecture=x86_64 -c Debug JavaScriptCore JSString
> I also tried different frameworks and classes. The script always fails telling me that "no type matches x in y" where x is the class name I used in the run and y is the framework name.
> Why is this happening? The script is correctly finding the built and symbolicated framework image, so why is it not working properly? Thanks in advance.
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org <mailto:webkit-dev at lists.webkit.org>
> https://lists.webkit.org/mailman/listinfo/webkit-dev <https://lists.webkit.org/mailman/listinfo/webkit-dev>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20181105/885c28a4/attachment.html>

More information about the webkit-dev mailing list