[webkit-dev] dump-class-layout script not working

Frank Jaeger fjaeger77 at outlook.com
Sun Nov 4 03:43:37 PST 2018

Hello. First of all I'm really sorry if this is the wrong mailing list to post to, webkit-help would have probably been better but it doesn't seem very active.

I run into some problems while trying to use the dump-class-layout script (found in Tools/Scripts/). I built WebKit using the build-webkit script with the --debug flag.

After building, I tried to run the dump-class-layout script with the following arguments:

./Tools/Scripts/dump-class-layout --architecture=x86_64 -c Debug JavaScriptCore JSString

I also tried different frameworks and classes. The script always fails telling me that "no type matches x in y" where x is the class name I used in the run and y is the framework name.

Why is this happening? The script is correctly finding the built and symbolicated framework image, so why is it not working properly? Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20181104/daedc7df/attachment.html>

More information about the webkit-dev mailing list