[webkit-dev] Move to NavigationClient
huperniketes at gmail.com
Sun Oct 22 09:22:59 PDT 2017
On Oct 20, 2017 4:30 PM, "Alex Christensen" <achristensen at apple.com> wrote:
Right now we have an API::LoaderClient, API::PolicyClient and an
API::NavigationClient. We intend to remove the first two in the future in
favor of the API::NavigationClient.
Is there a semantic model this design decision is based on?
>From the current semantic and architectural perspectives, it sounds like it
would be a mistake. Particularly merging navigation duties with policy. Not
helpful to all clients.
Apokalypse Software Corp
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev