[webkit-dev] Move to NavigationClient
achristensen at apple.com
Mon Oct 23 09:54:44 PDT 2017
I’m not sure I understand your concern. Deciding policies is definitely part of navigation. Why would it be important to have the clients be separate objects?
> On Oct 22, 2017, at 9:22 AM, Alfonso Guerra <huperniketes at gmail.com> wrote:
> On Oct 20, 2017 4:30 PM, "Alex Christensen" <achristensen at apple.com <mailto:achristensen at apple.com>> wrote:
> Right now we have an API::LoaderClient, API::PolicyClient and an API::NavigationClient. We intend to remove the first two in the future in favor of the API::NavigationClient.
> Is there a semantic model this design decision is based on?
> From the current semantic and architectural perspectives, it sounds like it would be a mistake. Particularly merging navigation duties with policy. Not helpful to all clients.
> Warmest regards,
> Alfonso Guerra
> Apokalypse Software Corp
> (626) 667-4285
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev