[webkit-dev] Should overridden methods use 'virtual' keyword in addition to 'override'?
rniwa at webkit.org
Thu Mar 3 09:54:29 PST 2016
I think "virtual" + "override" is more of a historical artifact than
the preferred style because we used to have OVERRIDE macro before all
compilers supported C++11. I think we should just use only "override"
- R. Niwa
On Thu, Mar 3, 2016 at 9:38 AM, Darin Adler <darin at apple.com> wrote:
> Antti proposed using only “override” a while back since it’s less verbose and still unambiguous. I don’t think we reached consensus on which style to prefer for the project, though.
> — Darin
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev