[webkit-dev] Should overridden methods use 'virtual' keyword in addition to 'override'?

Michael Catanzaro mcatanzaro at igalia.com
Thu Mar 3 10:47:51 PST 2016

On Thu, 2016-03-03 at 09:54 -0800, Ryosuke Niwa wrote:
> I think "virtual" + "override" is more of a historical artifact than
> the preferred style because we used to have OVERRIDE macro before all
> compilers supported C++11.  I think we should just use only
> "override"
> going forward.
> - R. Niwa

I agree, "virtual" in subclasses adds no value, it is simply redundant
with "override"... we should omit it in new files.

More information about the webkit-dev mailing list