[webkit-dev] unsigned vs unsigned int

Allan Sandfeld Jensen kde at carewolf.com
Mon Sep 17 01:22:11 PDT 2012

On Sunday 16 September 2012, Darin Adler wrote:
> On Sep 16, 2012, at 2:30 AM, Allan Sandfeld Jensen <kde at carewolf.com> wrote:
> > On Thursday 13 September 2012, Dan Bernstein wrote:
> >> On Sep 13, 2012, at 1:29 AM, Kenneth Rohde Christiansen 
<kenneth.christiansen at gmail.com> wrote:
> >>> I was telling people to use "unsigned" instead of "unsigned int", as I
> >>> have been told that was the preferred style before, but apparently
> >>> that is not in the style guide.
> >>> 
> >>> The question is, should it be?
> >> 
> >> Yes.
> > 
> > Why? Wouldn't it be better to move away from deprecated C syntax?
> I think we should use the shortest name for each type.
> That is why I like “unsigned” better than “unsigned int”.
Does this mean you also prefer 'const' over 'const int'? ;-)

Anyway, I have no strong opinion on the subject, like most programmers I just 
prefer what I am just to, and for some reason I am more used to 'unsigned int' 
than 'unsigned'. But I can easily live with it. This was only meant as a 
weekend comment.

Best regards.

More information about the webkit-dev mailing list