[webkit-dev] We should rename layoutTestController to testController
ojan at chromium.org
Thu May 31 14:01:36 PDT 2012
Darin, sorry for derailing this thread. I suppose I should have changed the
On Thu, May 31, 2012 at 1:51 PM, Jesus Sanchez-Palencia <jesus at webkit.org>wrote:
> Just a heads-up: there is a meta bug tracking this at
> https://bugs.webkit.org/show_bug.cgi?id=87284 .
> A few folks have been going through the list created during the
> hackathon (https://trac.webkit.org/wiki/Internals_Hackathon) and
> picking a method to port every now and then.
> We were following the
> "if-it-depends-only-on-WebCore-code-it-should-be-moved" idea quite
> strictly, but now it seems we are facing a trade-off about internals x
> private WebKit APIs/SPIs from a few ports being tested. In other
> words, a few methods from layoutTestController are also testing code
> (private?) from WebKit and moving them to internals can leave these
> untested... For Qt I'm removing private methods that were only used by
> DRT or WTR, but I can't make this decision for other ports.
If any of these involve the Chromium port, I'm sure we'd be happy to
accommodate whatever is needed to move the API to internals. Feel free to
CC me on bugs where that's the case.
> Anyway, if you know something that can be moved for sure, just open a
> bug blocking b87284 and I'm quite sure there will be people happy to
> work on it.
> > Work on exposing things like eventSender through an NPAPI plugin. That
> > it can be shared across browser vendors and could be used by the W3C test
> > harness as well. This would be for APIs that we want for testing but
> > make sense to expose to the web.
> > Ojan
> > On Thu, May 31, 2012 at 11:56 AM, Darin Adler <darin at apple.com> wrote:
> >> I am thinking we should rename layoutTestController to testController.
> >> if you don’t like that name, maybe testHarness or some even better name.
> >> The old name is too long and the word “layout” is so strange.
> >> We could expose the object under the new name and the old one, and then
> >> over time convert all the tests to the new name, then get rid of the old
> >> one.
> >> What do you all think?
> >> -- Darin
> >> _______________________________________________
> >> webkit-dev mailing list
> >> webkit-dev at lists.webkit.org
> >> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
> > _______________________________________________
> > webkit-dev mailing list
> > webkit-dev at lists.webkit.org
> > http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev