[webkit-dev] We should rename layoutTestController to testController
jesus at webkit.org
Thu May 31 13:51:16 PDT 2012
2012/5/31 Ojan Vafai <ojan at chromium.org>:
> testController seems fine to me. I agree it's an improvement.
> On the other hand there are other tasks that have more benefit in terms of
> code maintenance for people wanting to spend time working in this area. A
> couple ideas:
> Move more APIs that only depend WebCore code to internals. Reduces code
> duplication and complexity.
Just a heads-up: there is a meta bug tracking this at
A few folks have been going through the list created during the
hackathon (https://trac.webkit.org/wiki/Internals_Hackathon) and
picking a method to port every now and then.
We were following the
"if-it-depends-only-on-WebCore-code-it-should-be-moved" idea quite
strictly, but now it seems we are facing a trade-off about internals x
private WebKit APIs/SPIs from a few ports being tested. In other
words, a few methods from layoutTestController are also testing code
(private?) from WebKit and moving them to internals can leave these
untested... For Qt I'm removing private methods that were only used by
DRT or WTR, but I can't make this decision for other ports.
Anyway, if you know something that can be moved for sure, just open a
bug blocking b87284 and I'm quite sure there will be people happy to
work on it.
> Work on exposing things like eventSender through an NPAPI plugin. That way
> it can be shared across browser vendors and could be used by the W3C test
> harness as well. This would be for APIs that we want for testing but don't
> make sense to expose to the web.
> On Thu, May 31, 2012 at 11:56 AM, Darin Adler <darin at apple.com> wrote:
>> I am thinking we should rename layoutTestController to testController. Or
>> if you don’t like that name, maybe testHarness or some even better name.
>> The old name is too long and the word “layout” is so strange.
>> We could expose the object under the new name and the old one, and then
>> over time convert all the tests to the new name, then get rid of the old
>> What do you all think?
>> -- Darin
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev