[webkit-dev] We should rename layoutTestController to testController

Ryosuke Niwa rniwa at webkit.org
Thu May 31 12:11:23 PDT 2012

On Thu, May 31, 2012 at 11:56 AM, Darin Adler <darin at apple.com> wrote:

> I am thinking we should rename layoutTestController to testController. Or
> if you don’t like that name, maybe testHarness or some even better name.

"testController" seems like a misnomer since it doesn't really control the
test itself. I would prefer testRunnerController or simply testRunner since
it's quite self-evident that methods on testRunner would act on the test
runner itself.

We could expose the object under the new name and the old one, and then
> over time convert all the tests to the new name, then get rid of the old
> one.

That sounds like a good idea.

Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt)
suggested to cleanup the render tree dump format to get rid of all hacks
and tweaks we've added over years, and my preference is to combine all
these efforts and put new types of tests in trunk/RegressionTests. We'll
move tests from LayoutTests to RegressionTests as we convert. We'll get rid
of LayoutTests directory once all tests have been converted to use
testRunner and new render tree dump format.

- Ryosuke
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20120531/d5cb94c2/attachment.html>

More information about the webkit-dev mailing list