[webkit-dev] We should rename layoutTestController to testController
ojan at chromium.org
Thu May 31 12:07:10 PDT 2012
testController seems fine to me. I agree it's an improvement.
On the other hand there are other tasks that have more benefit in terms of
code maintenance for people wanting to spend time working in this area. A
- Move more APIs that only depend WebCore code to internals. Reduces
code duplication and complexity.
- Work on exposing things like eventSender through an NPAPI plugin. That
way it can be shared across browser vendors and could be used by the W3C
test harness as well. This would be for APIs that we want for testing but
don't make sense to expose to the web.
On Thu, May 31, 2012 at 11:56 AM, Darin Adler <darin at apple.com> wrote:
> I am thinking we should rename layoutTestController to testController. Or
> if you don’t like that name, maybe testHarness or some even better name.
> The old name is too long and the word “layout” is so strange.
> We could expose the object under the new name and the old one, and then
> over time convert all the tests to the new name, then get rid of the old
> What do you all think?
> -- Darin
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev