[webkit-dev] TestExpectations syntax changes, last call (for a while, at least) ...
dpranke at chromium.org
Wed Jun 13 17:04:41 PDT 2012
"Skip" and "WontFix" have a different purpose than "Crash" and
"timeout"; the first two (like "slow") tell you what to do with the
test, and the latter tell you what you expect the test to result in.
I don't want to combine them into single tokens because that would
cause an explosion of tokens :).
On Wed, Jun 13, 2012 at 4:55 PM, Tom Zakrajsek <tomz at codeaurora.org> wrote:
> As long as we're considering "TitleCase" for the keywords, could we use it
> to keep all of them as single words?
> WontFix, SkipCrash, SkipTimeout
> On Jun 13, 2012, at 4:46 PM, Dirk Pranke wrote:
> There's still a distinction between SKIP (temporary) and WONTFIX
> (permanent until some plan changes) that we should preserve, I think.
> It could be useful to indicate SKIP CRASH or SKIP TIMEOUT as well, but
> I agree that the type of failure will probably change over time.
> -- Dirk
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> On Jun 13, 2012 at 4:32 PM, Dirk Pranke <dpranke at chromium.org> wrote:
> So something like
> webkit.org/12345 [Win Mac Debug] animations/stop-animation-on-suspend.html
> [Crash Text Pass]
> ? I like that!
> This seems quite readable to me as well. As mentioned above, I'd be
> inclined to make the absence of  on the right hand side mean "SKIP".
More information about the webkit-dev