[webkit-dev] TestExpectations syntax changes, last call (for a while, at least) ...
rniwa at webkit.org
Wed Jun 13 17:05:18 PDT 2012
On Wed, Jun 13, 2012 at 4:55 PM, Tom Zakrajsek <tomz at codeaurora.org> wrote:
> As long as we're considering "TitleCase" for the keywords, could we use it
> to keep all of them as single words?
> WontFix, SkipCrash, SkipTimeout
For skipped tests, it doesn't make sense to have crash, timeout, etc...
because we wouldn't know even if failure types changed from text to crash,
or from timeout to image. It's just a pure noise as far as I'm concerned.
On Jun 13, 2012, at 4:46 PM, Dirk Pranke wrote:
> There's still a distinction between SKIP (temporary) and WONTFIX
> (permanent until some plan changes) that we should preserve, I think.
The way I see it, WontFix and NotImplemented, like bug URL, are orthogonal
to other test expectations. They tell us "why" we have a given test
expectation but doesn't define the expectation itself.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev