[webkit-dev] Fwd: Gamepad API [Was: New feature flag proposal: Joystick API]
scottmg at chromium.org
Thu Oct 13 07:15:18 PDT 2011
> Alexey Proskuryakov wrote:
> One way to come up with a good name for something already in existence is to
> look how other people call it. For example, a Wikipedia article on USB HID
> devices puts everything this spec cares about into "game controllers"
> section. How about GameController?
Yes, agreed, GameController was the third candidate that was discussed
in the WG (other than Joystick and Gamepad). Gamepad was favoured,
because "Controller" seemed to imply too much generality (cameras, et
al.). The discussion is in the minutes here for those interested
Personally, I see Gamepad as a representative name rather than
necessarily all encompassing. Analogously we use "Mouse" in other
specs. Many people use trackballs, trackpads, joystick-like devices,
etc. to control "some indexed buttons with a 2d location + scrolling
indications". This is because there's no particularly better word for
that input concept than "mouse". I believe this is the case for
Jerry Seeger <vikingjs at me.com> wrote:
> I read the scope, and it seems pretty clear, but it's worth asking: If you
> stated what you DO cover better, is it no longer necessary to state what you
> DON'T cover. If the scope is clear, why is the name so difficult? In this
> case a 'gamepad' has been defined as a collection of analog inputs with
> input values between either 0..1 or -1..1.From my (very brief) scanning of
> the spec, it seems like this is the 'bounded (or finite?) analog input
> collection' spec.
Thanks for the feedback. That does seem like a good way of summarizing
the scope, and I think we should include something like that in the
spec to help make things more explicit. As a name though,
boundedAnalogInputDeviceCollection seems a bit unwieldy.
More information about the webkit-dev