[webkit-dev] Gamepad API [Was: New feature flag proposal: Joystick API]
ap at webkit.org
Wed Oct 12 15:58:06 PDT 2011
12.10.2011, в 14:10, Adam Barth написал(а):
> I don't think it's worth blocking development of the feature based
> solely on the name.
Quoting what I actually said in the bug, "I don't think that we should accept an implementation of a spec that's so immature that it doesn't even have a meaningful name."
The issues that I see are:
- Immaturity that's manifesting itself even in the name. You can't really ask someone to meaningfully review a spec when its scope is so unclear.
- Spec development process that ignores feedback. Multiple people who want this feature (including one of spec editors) were aware of feedback but didn't act on it. We had consensus on webkit-dev that the name was bad, yet a patch was again posted for review in Bugzilla.
> I'd recommend sorting out the name issue before
> enabling the feature by default though, because that's the point in
> time after which changing the name will become painful. If the name
> is really a sticking point, you can always give the API a ridiculous
> name to force yourself to change it later.
- WBR, Alexey Proskuryakov
More information about the webkit-dev