[webkit-dev] Gamepad API [Was: New feature flag proposal: Joystick API]

Adam Barth abarth at webkit.org
Wed Oct 12 14:10:44 PDT 2011

I don't think it's worth blocking development of the feature based
solely on the name.  I'd recommend sorting out the name issue before
enabling the feature by default though, because that's the point in
time after which changing the name will become painful.  If the name
is really a sticking point, you can always give the API a ridiculous
name to force yourself to change it later.


On Wed, Oct 12, 2011 at 12:59 PM, Darin Fisher <darin at chromium.org> wrote:
> Hi all,
> Alexey appears to strongly dislike the name of this API specification
> (http://dvcs.w3.org/hg/webevents/raw-file/default/gamepad.html), so much so
> that he is blocking development of the API behind a flag.
> As a reminder, this API is being developed through the WebEvents WG jointly
> with other browser vendors, including Mozilla.  Folks working on this appear
> to be content with the Gamepad name, precisely because the spec is limited
> to dealing with input devices that are represented in terms of buttons and
> axes.  Gamepad seems like a fairly canonical name for such a device, even
> though devices by other names can be represented by similar data.
> Does anyone else feel strongly enough that the name of the API is so bad
> that it should therefore not be allowed onto WebKit trunk behind a flag?
> Personally, I feel like the name is quite malleable at this point in time,
> and I really like coming up with the best possible name for things.
>  However, I don't see why we need to have the perfect name before we
> continue development of this feature behind a flag.
> As we were developing Blob and File support, we made several name changes
> along the way.  It is not always so obvious how to name things from the
> start.
> See this bug for reference:
> https://bugs.webkit.org/show_bug.cgi?id=69451
> Thoughts?
> -Darin
> On Thu, Oct 6, 2011 at 2:07 PM, Alexey Proskuryakov <ap at webkit.org> wrote:
>> 06.10.2011, в 13:49, Scott Graham написал(а):
>> The first revision of the spec (from the Scope section) is intended to
>> handle:
>> ... support for devices common to current gaming systems including
>> gamepads, directional pads, joysticks, wheels, pedals, accelerometers.
>> Why does the spec title and abstract talk about gamepads (joysticks)
>> only? Perhaps it's my mistake that I didn't read the scope section, but with
>> title and abstract being so specific, that seemed unnecessary.
>> Skipping scope section, I went right to IDL. Why is the interface called
>> Gamepad if it's not only about gamepads?
>> - WBR, Alexey Proskuryakov
>> _______________________________________________
>> webkit-dev mailing list
>> webkit-dev at lists.webkit.org
>> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list