[webkit-dev] Gamepad API [Was: New feature flag proposal: Joystick API]
pkasting at google.com
Wed Oct 12 16:25:35 PDT 2011
On Wed, Oct 12, 2011 at 3:58 PM, Alexey Proskuryakov <ap at webkit.org> wrote:
> Quoting what I actually said in the bug, "I don't think that we should
> accept an implementation of a spec that's so immature that it doesn't even
> have a meaningful name."
That the name is not meaningful, and that this is a sign of too great of
spec immaturity, are both judgment calls. I don't happen to agree with your
judgment in either case (not that my own judgment is objectively better).
There's been a noteworthy lack of good alternative ideas for the name
("joystick" has similar issues to "gamepad", whereas "input device" or
similar are clearly far too broad for what the spec covers; in the end I
agree with Darin that the name is fine overall), and in that context I'm not
sure the name is evidence for spec immaturity.
We had consensus on webkit-dev that the name was bad, yet a patch was again
> posted for review in Bugzilla.
"Consensus" seems somewhat strong. Looking over the emails sent, you
expressed some concern, but there was not a ton of discussion beyond that.
I read the tone of the thread as generally OK with things. (If that hadn't
been the case I would have sent this email earlier.)
As Adam notes, we should be confident of the name before we turn it on by
default, but I don't think that should block development, and I also think
it would behoove people unhappy with the name to offer some clearly-superior
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev